← ツール一覧

開発

HTTPステータスコード辞典

HTTPの応答コードを検索。意味・用途・対処のヒント。

入力データはこのブラウザ内で処理されます。サーバーには送信しません。

100Continue

リクエスト本文を送信してよいという中間応答。

用途・対処のヒント

Expect: 100-continueのやり取りで使用します。最終応答を続けて確認します。

[RFC9110, Section 15.2.1]

101Switching Protocols

通信プロトコルの切り替えを受け入れた応答。

用途・対処のヒント

Upgradeヘッダーと切り替え先のプロトコルを確認します。

[RFC9110, Section 15.2.2]

102Processing

処理が続いていることを伝える中間応答。

用途・対処のヒント

WebDAV由来のコードです。後続の最終応答を確認します。

[RFC2518]

103Early Hints

最終応答の前にリンク等のヒントを通知。

用途・対処のヒント

ブラウザやCDNのEarly Hintsへの対応を確認します。

[RFC8297]

104Upload Resumption Supported

アップロード再開への対応を示す中間応答。

用途・対処のヒント

暫定登録です。2026年11月13日の期限と最新のIANA登録・ドラフトを確認してください。

[draft-ietf-httpbis-resumable-upload-05]

200OK

リクエストの処理が成功。

用途・対処のヒント

内容の意味はメソッドによって異なります。期待する本文とContent-Typeを確認します。

[RFC9110, Section 15.3.1]

201Created

新しいリソースを作成。

用途・対処のヒント

Locationヘッダーや応答本文から作成されたリソースを確認します。

[RFC9110, Section 15.3.2]

202Accepted

処理要求を受け付けたが、処理は未完了。

用途・対処のヒント

完了を保証する応答ではありません。処理状況の確認先を参照します。

[RFC9110, Section 15.3.3]

203Non-Authoritative Information

元のサーバーからの応答を仲介者が変更。

用途・対処のヒント

プロキシや変換処理が応答へ影響していないか確認します。

[RFC9110, Section 15.3.4]

204No Content

処理は成功し、応答本文はなし。

用途・対処のヒント

JSON等の本文を読み込もうとしないようクライアント側を調整します。

[RFC9110, Section 15.3.5]

205Reset Content

処理が完了し、入力画面等のリセットを要求。

用途・対処のヒント

本文はありません。フォームなどの表示状態をリセットします。

[RFC9110, Section 15.3.6]

206Partial Content

要求した範囲の内容を返す部分応答。

用途・対処のヒント

RangeとContent-Range、分割された内容を確認します。

[RFC9110, Section 15.3.7]

207Multi-Status

複数の処理結果をまとめて返す応答。

用途・対処のヒント

WebDAVの応答本文に含まれる各リソースのステータスを確認します。

[RFC4918]

208Already Reported

同じリソースの情報がすでに報告済み。

用途・対処のヒント

WebDAVの重複列挙を避けるためのコードです。Multi-Status内の結果を確認します。

[RFC5842]

226IM Used

インスタンス操作を適用した表現を返す応答。

用途・対処のヒント

差分転送の仕様とIM等のヘッダーを確認します。

[RFC3229]

300Multiple Choices

リソースに複数の選択肢がある。

用途・対処のヒント

応答本文やLocationを参照して適切な取得先を選びます。

[RFC9110, Section 15.4.1]

301Moved Permanently

リソースが恒久的に別のURIへ移動。

用途・対処のヒント

Locationとリダイレクト経路を確認します。POSTがGETへ変わる実装がある点に注意します。

[RFC9110, Section 15.4.2]

302Found

リソースが一時的に別のURIへ移動。

用途・対処のヒント

Locationを確認します。メソッド維持が必要な場合は307の仕様と比較します。

[RFC9110, Section 15.4.3]

303See Other

処理結果を別のURIから取得するよう指示。

用途・対処のヒント

通常はLocationの取得先へGETで移動します。フォーム送信後の再送防止にも使われます。

[RFC9110, Section 15.4.4]

304Not Modified

条件付き取得で、保存済みの表現を利用できる。

用途・対処のヒント

本文はありません。ETagやLast-Modifiedとクライアント側のキャッシュを確認します。

[RFC9110, Section 15.4.5]

305Use Proxy

プロキシの使用を指示する旧コード。

用途・対処のヒント

現在は非推奨です。新しい実装での使用は避け、現行仕様を参照します。

[RFC9110, Section 15.4.6]

306(Unused)

現在は使用されていない予約コード。

用途・対処のヒント

通常の応答として実装しません。登録上の意味と独自実装を区別します。

[RFC9110, Section 15.4.7]

307Temporary Redirect

メソッドを維持して一時的に別のURIへ移動。

用途・対処のヒント

POST等のメソッドと本文を維持します。Locationと移動先の安全性を確認します。

[RFC9110, Section 15.4.8]

308Permanent Redirect

メソッドを維持して恒久的に別のURIへ移動。

用途・対処のヒント

恒久移動かつメソッド・本文を維持します。キャッシュの影響も確認します。

[RFC9110, Section 15.4.9]

400Bad Request

リクエストの形式等に問題があり処理できない。

用途・対処のヒント

URL、ヘッダー、JSON等の構文とサーバーの入力条件を確認します。

[RFC9110, Section 15.5.1]

401Unauthorized

対象リソースに有効な認証情報が必要。

用途・対処のヒント

WWW-Authenticateと認証方式を確認し、必要なら再認証します。

[RFC9110, Section 15.5.2]

402Payment Required

将来の使用に備えて予約されたコード。

用途・対処のヒント

標準で詳細な用途は定義されていません。サービス独自の課金仕様と区別します。

[RFC9110, Section 15.5.3]

403Forbidden

要求を理解したがアクセスを拒否。

用途・対処のヒント

権限、IP制限、サーバー設定を確認します。認証のやり直しだけでは解消しない場合があります。

[RFC9110, Section 15.5.4]

404Not Found

要求したリソースが見つからない、または存在を開示しない。

用途・対処のヒント

URL、ファイル配置、ルーティングを確認します。削除の恒久性を示すコードではありません。

[RFC9110, Section 15.5.5]

405Method Not Allowed

対象リソースでは要求メソッドを使用できない。

用途・対処のヒント

Allowヘッダーを確認し、GET・POST等の指定を修正します。

[RFC9110, Section 15.5.6]

406Not Acceptable

要求された応答形式を提供できない。

用途・対処のヒント

AcceptやAccept-Language等の条件と提供可能な形式を確認します。

[RFC9110, Section 15.5.7]

407Proxy Authentication Required

プロキシへの認証が必要。

用途・対処のヒント

Proxy-Authenticateおよびプロキシの認証設定を確認します。

[RFC9110, Section 15.5.8]

408Request Timeout

リクエストを受け取るまでに時間切れ。

用途・対処のヒント

接続や送信速度を確認します。再送する場合は処理の重複に注意します。

[RFC9110, Section 15.5.9]

409Conflict

リソースの現在の状態とリクエストが競合。

用途・対処のヒント

競合情報を確認し、最新の状態を取得してから更新をやり直します。

[RFC9110, Section 15.5.10]

410Gone

リソースが利用できず、その状態が恒久的と考えられる。

用途・対処のヒント

古いリンクや参照先を更新します。サーバー側では削除方針を確認します。

[RFC9110, Section 15.5.11]

411Length Required

リクエストにContent-Lengthが必要。

用途・対処のヒント

送信する本文の長さとサーバーの受信条件を確認します。

[RFC9110, Section 15.5.12]

412Precondition Failed

リクエストの事前条件が成立しない。

用途・対処のヒント

If-Match等と現在のETag・更新日時を確認します。

[RFC9110, Section 15.5.13]

413Content Too Large

リクエストの内容が大きすぎる。

用途・対処のヒント

本文・アップロードのサイズと、アプリ・プロキシ双方の上限を確認します。

[RFC9110, Section 15.5.14]

414URI Too Long

リクエストURIが長すぎる。

用途・対処のヒント

クエリ文字列やリダイレクトのループを確認します。

[RFC9110, Section 15.5.15]

415Unsupported Media Type

リクエストのメディアタイプ等を受け付けられない。

用途・対処のヒント

Content-Type、Content-Encoding、送信したデータ形式を確認します。

[RFC9110, Section 15.5.16]

416Range Not Satisfiable

要求したデータ範囲を提供できない。

用途・対処のヒント

Rangeと対象のサイズを確認し、適切な範囲で再取得します。

[RFC9110, Section 15.5.17]

417Expectation Failed

Expectヘッダーの期待を満たせない。

用途・対処のヒント

Expectの指定と経路上のサーバー・プロキシの対応を確認します。

[RFC9110, Section 15.5.18]

418(Unused)

現行HTTP仕様では未使用として予約。

用途・対処のヒント

I’m a teapotとして知られますが、一般用途の標準エラーではありません。

[RFC9110, Section 15.5.19]

421Misdirected Request

要求を処理できないサーバーへ送られている。

用途・対処のヒント

接続の再利用、Host、TLSのホスト名やリバースプロキシを確認します。

[RFC9110, Section 15.5.20]

422Unprocessable Content

内容の形式は理解できるが、指示を処理できない。

用途・対処のヒント

構文が正しくても項目の値や業務上の条件が不適切な場合があります。入力条件を確認します。

[RFC9110, Section 15.5.21]

423Locked

対象リソースがロックされている。

用途・対処のヒント

WebDAV等のロック状態、所有者と解除手続きを確認します。

[RFC4918]

424Failed Dependency

依存する別の処理が失敗したため処理できない。

用途・対処のヒント

先行処理の結果を確認し、依存関係を解消します。

[RFC4918]

425Too Early

リプレイされる危険のある要求を処理しない。

用途・対処のヒント

TLSの早期データを使わない接続で再試行するなど、クライアントの実装を確認します。

[RFC8470]

426Upgrade Required

別のプロトコルへのアップグレードが必要。

用途・対処のヒント

Upgradeヘッダーと必要なプロトコルを確認します。

[RFC9110, Section 15.5.22]

428Precondition Required

条件付きリクエストが必要。

用途・対処のヒント

競合防止のためIf-Match等、サーバーが要求する事前条件を付けます。

[RFC6585]

429Too Many Requests

一定時間内のリクエストが多すぎる。

用途・対処のヒント

Retry-Afterがあれば従い、間隔を空けて再試行します。連続した自動再送は避けます。

[RFC6585]

431Request Header Fields Too Large

リクエストヘッダーが大きすぎる。

用途・対処のヒント

Cookieや認証ヘッダー等のサイズを確認します。

[RFC6585]

451Unavailable For Legal Reasons

法的理由によりアクセスできない。

用途・対処のヒント

応答の説明や関連するリンクを確認します。技術設定だけで解消できるとは限りません。

[RFC7725]

500Internal Server Error

サーバー内部で予期しない問題が発生。

用途・対処のヒント

サーバーのエラーログ、アプリの例外、設定や権限を確認します。

[RFC9110, Section 15.6.1]

501Not Implemented

要求を処理するための機能を実装していない。

用途・対処のヒント

要求メソッドやサーバーの機能対応を確認します。

[RFC9110, Section 15.6.2]

502Bad Gateway

ゲートウェイが上流から不正な応答を受け取った。

用途・対処のヒント

上流アプリ、プロキシ設定、接続やプロトコルを確認します。

[RFC9110, Section 15.6.3]

503Service Unavailable

過負荷や保守等で一時的にサービスを提供できない。

用途・対処のヒント

Retry-Afterがあれば従います。サーバー負荷や保守状況を確認します。

[RFC9110, Section 15.6.4]

504Gateway Timeout

ゲートウェイが上流からの応答を待って時間切れ。

用途・対処のヒント

上流の処理時間と、プロキシ・アプリ側のタイムアウトを確認します。

[RFC9110, Section 15.6.5]

505HTTP Version Not Supported

要求されたHTTPバージョンに対応しない。

用途・対処のヒント

クライアントとサーバーのHTTPバージョン・経路を確認します。

[RFC9110, Section 15.6.6]

506Variant Also Negotiates

コンテンツネゴシエーションの設定が循環。

用途・対処のヒント

サーバーの選択肢・派生表現の設定を確認します。

[RFC2295]

507Insufficient Storage

要求を完了するための保存領域が不足。

用途・対処のヒント

WebDAV等の保存先の空き容量・クォータを確認します。

[RFC4918]

508Loop Detected

要求の処理中に無限ループを検出。

用途・対処のヒント

WebDAVのバインディングや再帰的な処理を確認します。

[RFC5842]

511Network Authentication Required

ネットワークへ接続するための認証が必要。

用途・対処のヒント

公衆Wi-Fi等のネットワーク認証を確認します。アプリのログインとは区別します。

[RFC6585]

この辞典の範囲

IANAのHTTPステータスコード登録簿を2026年10月3日に確認し、登録済みの番号を掲載しています。未割り当ての番号や独自コードは含めません。104は暫定登録、305は非推奨、306・418は未使用、402は用途の詳細が未定義、510は廃止扱いです。418の俗称「I’m a teapot」等と現行の登録状態を区別します。

413の旧名称「Payload Too Large」、422の旧名称「Unprocessable Entity」も検索できます。原因は構成やサービスによって異なるため、ヒントだけで断定せず応答本文・ヘッダー・ログも確認してください。

出典:IANA HTTP Status Code Registry。暫定コード等は変更される場合があります。

HTTPステータスコード辞典の使い方

  1. ステータス番号・名称・キーワードを入力するか、分類で絞り込みます。
  2. 各コードの意味と対処のヒントを確認します。
  3. コードの説明をコピーできます。仕様の詳細はIANA・RFCのリンクから確認してください。
すべてのWebツールを見る →